CVE-2022-37437: Amazon vulnerability

Published by CVE Tracker on

When using Ingest Actions to configure a destination that resides on Amazon Simple Storage Service (S3) in Splunk Web, TLS certificate validation is not correctly performed and tested for the destination. The vulnerability only affects connections between Splunk Enterprise and an Ingest Actions Destination through Splunk Web and only applies to environments that have configured TLS certificate validation. It does not apply to Destinations configured directly in the outputs.conf configuration file. The vulnerability affects Splunk Enterprise version 9.0.0 and does not affect versions below 9.0.0, including the 8.1.x and 8.2.x versions.

How to mitigate CVE-2022-37437

Time needed: 5 minutes.

The instructions will assist you in mitigating CVE-2022-37437. In some specific Amazon cases, more steps might be needed to fully mitigate CVE-2022-37437.

  • Utilize the references

    The CVE-2022-37437 references have been provided for a reason. Utilize these references and make sure that you are correctly informed.

  • References

  • www.splunk.com/en_us/product-security/announcements/svd-2022-0801.html
  • Share this information
    Categories: CVE