CVE-2022-0215: WordPress plugin vulnerability

Published by CVE Tracker on

The Login/Signup Popup, Waitlist Woocommerce ( Back in stock notifier ), and Side Cart Woocommerce (Ajax) WordPress plugins by XootiX are vulnerable to Cross-Site Request Forgery via the save_settings function found in the ~/includes/xoo-framework/admin/class-xoo-admin-settings.php file which makes it possible for attackers to update arbitrary options on a site that can be used to create an administrative user account and grant full privileged access to a compromised site. This affects versions <= 2.2 in Login/Signup Popup, versions <= 2.5.1 in Waitlist Woocommerce ( Back in stock notifier ), and versions <= 2.0 in Side Cart Woocommerce (Ajax).

How to mitigate CVE-2022-0215

Time needed: 5 minutes.

Follow the instructions, as they will assist you in mitigating the WordPress vulnerability that been reported in CVE-2022-0215.

  1. Install the latest version of WordPress

    Navigate to the official WordPress website and download the latest version of WordPress. The latest version contains the CVE-2022-0215 fix.
    Update to the latest version

  2. Perform a vulnerability assessment

    Perform a scan on your WordPress environment(s), and check for vulnerabilities. Verify if CVE-2022-0215 has been mitigated.

  3. Utilize the references

    The CVE-2022-0215 references have been provided for a reason. Utilize these references and make sure that you are correctly informed.

References

  • plugins.trac.wordpress.org/browser/easy-login-woocommerce/tags/2.2/includes/xoo-framework/admin/class-xoo-admin-settings.php#L122
  • plugins.trac.wordpress.org/browser/easy-login-woocommerce/tags/2.2/includes/xoo-framework/admin/class-xoo-admin-settings.php#L122
  • plugins.trac.wordpress.org/browser/side-cart-woocommerce/tags/2.1/includes/xoo-framework/admin/class-xoo-admin-settings.php?rev=2538194#L128
  • plugins.trac.wordpress.org/browser/side-cart-woocommerce/tags/2.1/includes/xoo-framework/admin/class-xoo-admin-settings.php?rev=2538194#L128
  • plugins.trac.wordpress.org/browser/waitlist-woocommerce/tags/2.5.1/includes/xoo-framework/admin/class-xoo-admin-settings.php#L122
  • plugins.trac.wordpress.org/browser/waitlist-woocommerce/tags/2.5.1/includes/xoo-framework/admin/class-xoo-admin-settings.php#L122
  • wordfence.com/vulnerability-advisories/#CVE-2022-0215
  • wordfence.com/vulnerability-advisories/#CVE-2022-0215
  • www.wordfence.com/blog/2022/01/84000-wordpress-sites-affected-by-three-plugins-with-the-same-vulnerability/
  • www.wordfence.com/blog/2022/01/84000-wordpress-sites-affected-by-three-plugins-with-the-same-vulnerability/
  • Share this information