CVE-2020-9514: WordPress plugin vulnerability

Share this with people that should know this:

An issue was discovered in the IMPress for IDX Broker plugin before 2.6.2 for WordPress. wrappers.php allows a logged-in user (with the Subscriber role) to permanently delete arbitrary posts and pages, create new posts with arbitrary subjects, and modify the subjects of existing posts and pages (via create_dynamic_page and delete_dynamic_page).

References

  • wordpress.org/plugins/idx-broker-platinum/#developers
  • www.wordfence.com/blog/2020/03/vulnerabilities-patched-in-impress-for-idx-broker/
  • Share this with people that should know this: