Cheat sheets

CVE-2020-9456: WordPress plugin vulnerability

Share this with people that should know this:

In the RegistrationMagic plugin through 4.6.0.3 for WordPress, the user controller allows remote authenticated users (with minimal privileges) to elevate their privileges to administrator via class_rm_user_controller.php rm_user_edit.

References

  • wordpress.org/plugins/custom-registration-form-builder-with-submission-manager/#developers
  • wpvulndb.com/vulnerabilities/10116
  • www.wordfence.com/blog/2020/03/multiple-vulnerabilities-patched-in-registrationmagic-plugin/
  • Share this with people that should know this: