Type to search

CVE

CVE-2020-4049: WordPress vulnerability

In affected versions of WordPress, when uploading themes, the name of the theme folder can be crafted in a way that could lead to JavaScript execution in /wp-admin on the themes page. This does require an admin to upload the theme, and is low severity self-XSS. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

References

  • github.com/WordPress/wordpress-develop/security/advisories/GHSA-87h4-phjv-rm6p
  • github.com/WordPress/wordpress-develop/security/advisories/GHSA-87h4-phjv-rm6p
  • github.com/WordPress/wordpress-develop/commit/404f397b4012fd9d382e55bf7d206c1317f01148
  • github.com/WordPress/wordpress-develop/commit/404f397b4012fd9d382e55bf7d206c1317f01148
  • wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
  • wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
  • Share this info with your network:
    Tags: