Type to search

CVE

CVE-2020-4048: WordPress vulnerability

In affected versions of WordPress, due to an issue in wp_validate_redirect() and URL sanitization, an arbitrary external link can be crafted leading to unintended/open redirect when clicked. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

References

  • github.com/WordPress/wordpress-develop/security/advisories/GHSA-q6pw-gvf4-5fj5
  • github.com/WordPress/wordpress-develop/security/advisories/GHSA-q6pw-gvf4-5fj5
  • github.com/WordPress/wordpress-develop/commit/6ef777e9a022bee2a80fa671118e7e2657e52693
  • github.com/WordPress/wordpress-develop/commit/6ef777e9a022bee2a80fa671118e7e2657e52693
  • wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
  • wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
  • Share this info with your network:
    Tags: