CVE-2020-4047: WordPress vulnerability

In affected versions of WordPress, authenticated users with upload permissions (like authors) are able to inject JavaScript into some media file attachment pages in a certain way. This can lead to script execution in the context of a higher privileged user when the file is viewed by them. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

References

  • github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27
  • github.com/WordPress/wordpress-develop/security/advisories/GHSA-8q2w-5m27-wm27
  • github.com/WordPress/wordpress-develop/commit/0977c0d6b241479ecedfe19e96be69f727c3f81f
  • github.com/WordPress/wordpress-develop/commit/0977c0d6b241479ecedfe19e96be69f727c3f81f
  • wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
  • wordpress.org/news/2020/06/wordpress-5-4-2-security-and-maintenance-release/
  • Share this info: