CVE-2020-12675: WordPress plugin vulnerability

Share this with people that should know this:

The mappress-google-maps-for-wordpress plugin before 2.54.6 for WordPress does not correctly implement capability checks for AJAX functions related to creation/retrieval/deletion of PHP template files, leading to Remote Code Execution. NOTE: this issue exists because of an incomplete fix for CVE-2020-12077.

References

  • blog.alertlogic.com/alert-logic-threat-research-team-identifies-new-vulnerability-cve-2020-12675-in-mappress-plugin-for-wordpress/
  • wordpress.org/plugins/mappress-google-maps-for-wordpress/#developers
  • Share this with people that should know this: